Wir fPDF noch weiterentwickelt? PHP 5.6?

Alles andere zum Thema FPDF und PDF Format
mw197
Benutzer
Beiträge: 4
Registriert: So 28. Sep 2014, 11:29

Wir fPDF noch weiterentwickelt? PHP 5.6?

Beitragvon mw197 » So 28. Sep 2014, 11:34

Hallöchen,

ich nutze fPDF bei einigen Sachen und möchte es jetzt auch in einem großen Projekt verwenden. Meine Frage ist nur, ob fPDF noch weiterentwickelt wird.

Habe seit Jahren kein einziges Update sehen können.

Außerdem möchte ich fPDF für PHP 5.6 nutzen. Hat das jemand schon getestet?
Klappt das?

Würde mich über Antworten freuen!
LG

supertramp
Erfahrener Benutzer
Beiträge: 1305
Registriert: So 19. Sep 2004, 15:51

Beitragvon supertramp » Fr 3. Okt 2014, 17:56

Ich habe es noch nicht unter PHP 5.6 getestet, aber warum sollte es in der Version nicht lauffähig sein?

Warum sollte es permanent weiterentwickelt werden?
Ggf. kann es alles das, was es aktuell können soll?!
Fragen zu PHP?
1) Handbuch lesen: www.php.net
2) selbst probieren
3) google fragen
4) andere fragen: www.developers-guide.net
5) PHP-Tutorial - erste Schritte mit PHP

Hilfe in PHP/FPDF gesucht?
--> mykro.de

silvaner
Benutzer
Beiträge: 2
Registriert: So 26. Okt 2014, 14:59

Beitragvon silvaner » Mo 27. Okt 2014, 10:51

Ich finde auch, dass fpdf alles kann, was es soll. (Oder was ich brauche.)

Eine weitere Pflege ist dennoch nötig:

Code: Alles auswählen

 PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in /home/web/sites/rheinhessenwein24/inc/pdf/fpdf.php



Deprecated heißt ganz klar, dass in irgendeiner PHP Version mal Schluss ist.

Würde mich freuen, wenn es da weiter geht. Somit ist mw197s Frage noch offen. Auch ich würde mich über eine Antwort freuen. ;-)

silvaner
Benutzer
Beiträge: 2
Registriert: So 26. Okt 2014, 14:59

Beitragvon silvaner » Mo 27. Okt 2014, 12:19

Sorry,

der Fehler oben ist bereits behoben. Ich hatte den Code nur kurz gesichtet, statt zu installieren. Nun habe ich die aktuelle fpdf Version (+php 5.3) und es kommt keine Fehlermeldung mehr.

Erfahrungsgemäß habe die Entwickler die auf deprecated-Meldungen reagieren, keine Probleme beim Umstieg auf eine höhere PHP Version.


Zurück zu „Sonstiges“

Wer ist online?

Mitglieder in diesem Forum: Yahoo [Bot] und 1 Gast